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SIGIS Tutorials

Foreword

The following tutorials will gives you the opportunity to learn how to use the SIGIS
powerfull 6IS utilities and to realize all the advantages of the use of both vector
and raster data within an integrated and georeferenced univers. They are using the
same data set related to an area of the Jacques-Cartier valley located North-East
of Quebec City, Province of Québec, Canada. Public satellite imagery data found
on GeoGratis site (http://www.geogratis.ca/) were used. Vector data were digitized
from a EMR 1:50 000 paper map. The first tutorial is concerned by the creation of
a forestry map from a digital satellite image. The second one is concerned by the
erection of a storage dam on the Jacques-Cartier river. You will create and
explore a digital elevation model to find the best location to fix a dam. Then, you
will build a virtual dam, fix it into the landscape and therefore increase the water
level behind it. You will see the flooded area. Finaly, the third tutorial is
concerned by the evaluation of the impact on the environment related to the
construction of the dam and the realisation of a new road path development
proposition with respect to several criterions. Notify that these tutorials should be
used with a screen resolution of 1024 x 768 pixels or more and a colour depth of
16 777 216 (24 bits or more from the Display item of the Windows configuration
pannel). Notify also that you won't be able to do the tutorials if your color depth
has been fixed to only 256 colors.

Important ...

Use the online help available for all functions. See the help topic « Getting
started » showing how to start a SIGIS session before beginning these tutorials.

Data decompression

Data are compresssed ina "zip" file located on the internet site (www.sigisco.com). You
must have "WinZip" (www.winzip.com) installed to perform the decompression. Notify
the exact directory location and name where you extract data. You will need it later.

Legend
Application menu
Miscellenious file name
Raster map name
Vector map name
« Button »

"Dialog Box or command name"
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Starting SIGIS for the first time

Select Start -> Programs -> SIGISCO -> SIGIS on the Window's task bar. The SIGIS
baniere appears, then press the "Esc" key. A message shows which SIGIS version you
are actually working on, press the « OK » button. The "Univers" dialog box will be
displayed, this box allows you to select the current working directory. Now, you must
create a new univers. Start to choose the location of your new univers by browsing the
folders. Double click on a folder to open it. The current folder name appears en gray in
the upper part of the dialog box. Once you have chosen your univers location, press on
the « New » button. Another dialog box will appear. Write the name you want to assign
to your new univers. Then press the « OK » button to close this dialog box and again the
« OK » button to close the Univers dialog box.

The "Projection" dialog box is displayed. This box allows you to modify the default
projection parameters of your univers. Do not change anything for the moment and press
the « OK » button.

The "Region" dialog box will be displayed. Look at the various parameters found but do
not change the value of any of them. Press the « Set as default » button and the « OK
» button. This will initialize the geographical application parameters. These parameters
will be modified later. SIGIS is actually started.

Note ...

For ergonomic reasons, we recommend to maximize the main Application window.
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Tutorial 1

Creating a forestry map using satellite imagery™**

You will now create a forestry map using a Landsat 5 Thematic Mapper scene. This
scene is contained in the file tm.bsg located in the directory where you ahave already
extract the compressed tutorial data. The BSQ format is widely used to record
satellite imagery data. The informations required to be able to import the tm.bsg are
located in a file named tm.Adr. This is a text file which can be opened by any text
editor y compris, bien sur, celui de SIGIS. The SIGIS text editor can be started by
using the option :

Publishing -> Edit text file

Open the tm.hdr file first and import the images in the SIGIS image-format using the
option :

Imagery -> Import -> Raw image

Press on the « Select File » button and select the fm.bsg file. Use tm as prefix. Press
on the « Projection » button and specify the projection's parameters as they are
expressed in the tm.Adr file. Press on the « OK » button, then fill the blank using the
information contained in the tm.hdr file. Once done, press « OK », and close the dialog
box and the text editor.

This scene contains 5 spectral bands. Each band is in fact a distinct image showing the
ground reflectify in a part of the electromagnetic spectrum. The 5 bands are :

tm.b1: blue

tm.b2: green

tm.b3: red

tm.b4: near infrared
tm.b5: middle infrared

Fix the working region on the image #m.b1 using the option :
General -> Region

Select the « Raster » option of "Set From File:" and choose the tm.b1 raster map. Press
the « Set as default » button and then the « OK » button.

*** If you are not concerned by digital image processing you can start with tutorial 2.
The result of tutorial 1 is an image showing different types of vegetation. A copy of
this result called foret.tif is available in the tutorial data. You can import that copy
using Imagery -> Import -> Tiff image. This will be required to do tutorial 3.
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Start a monitor to display vector, raster maps and imagery using option :
Display -> Start Display Monitor
Monitor O is now created and displayed. You can increase the monitor size by selecting

the lower right corner with the mouse cursor. For ergonomic reasons, we do not
recommend to maximise it entirely.

Important ...

We stongly recommend to consult the available help topics concerning the monitor's
drop down menu. This menu is available by clicking the right mouse button in the
monitor.

Now, you will create and display a color composite image. Use bands tm.63, tm.b4 and
tm.b5. This image will enhance the forest caracteristics. First of all, you will explore
the spectral behaviour of each band by displaying its frequencies histogram. This
histogram shows the number of times each reflectance value is found in the band. Here
we want to learn what are the significatives reflectance values of each band to be able
to increase its contrast.

Choose :
Imagery -> Histogram

Select fm.b3 and press the « Display » button. Notify the minimum and maximum
"digital values" located on both sides of the bell looking distribution (not the
frequencies !). To do this, click the left mouse button while the mouse cursor is in the
histogram. You will see the associated frequency to each digital value. Discard low
digital values located on both sides of the distribution. Redo the same thing with tm.64
and 7m.b5 et keep in mind (or on a piece of paper) these values. Close the "Histogram"
window.

Choose therefore :
Display -> Display Image

Select tm.b3 in Plane 1, tm.b4 in Plane 2 and #m.65 Plane 3. Fill the minimum and
maximum edit control for each plane with the values you have written previously. Press
the « Load images » button then on the « Display images » button. Now, band #m.b3 is
sent in the video red gun, band #m.64 is sent in video green gun and band #m.65 in the
video blue gun. It is not the classic composite image used in forestry. To get it, click on
the « B » (Blue) button of Plane 1 and on the « R » (Red) button of Plane 2, Plane 3 will
adjust automaticly. Then press on « Display images » and close the Display image dialog
box. You should get the following composite image.
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Note ...
If you encounter any difficulty fo get a good composite image, use the following values :
Plane 1 (tm.b3)blue :min=0 max = 20

Plane 2 (tm.b4)red  :min=10 max = 130
Plane 3 (tm.b5)green : min=25 max = 100

Clicking the right mouse button in the monitor, use the option:
Region -> Fit monitor on ... -> Raster

then use :

Region -> Seft region

and press on « OK ». This will make sure that the Region will be perfectly fitted over
the displayed image.

Optionnal ...

You can save this composite image as a raster map using « Save as rasfer » button of
the Display image dialog box. Name this map composel.
You can now display this image using option :

Display -> Display Raster

Notify that the colour depth of this resulting raster map is only of 256 colors with
respect to a maximum of 16 777 216 used by the 3 planes display.

You can also start a second monitor to display composel and therefore compare the 2
display functions.
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The colour composite image can be interpreted according to the following rules :

o black : water

. cyan : bare soil

. light orange : deciduous

. dark orange : mixed (coniferious and deciduous)
. red brown : coniferious

. light green : regeneration

Notify that in principle, it is possible to extract as many as 15 classes from that kind of
colour composite image but to learn how it works 6 classes are largely enough.

Now, you will realize a superfised classification. You will obtain as result a raster map
also called classified image showing the 6 previously defined classes.

First of all, you must tell SIGIS how to recognize the different kind of object images.
This will be done using training sites. These sites are small polygons covering
homogeneous parts of the image for which the nature of the object is perfectly known
(ex. water or bare soil).

Choose :
Imagery -> Classification -> Training and Verification site acquisition

You must make sure to assign the same "colour", the same "class number" and the same
“class label" to the training site related o the same king of object. Feel free to use the

fonctions ZOOM forward @ and backward g to reach more accurate results. Use
the option Region -> View entire of the monitor's drop down menu to zoom to come back
to the default zoom level of this monitor. The ZOOM variations will not affect directly
the region on which the processing is done. Make sure to digitize at least 2 sites per
classes. Make also sure to follow the steps in the right order, its very important.

For each training site, repeat the following steps :

1. Ajust your ZOOM level over the selected homogeneous area (ex. water will be very
close to black).

Select a "Class value" (ex. 1 for water) or create a new class by selecting "New".

3. Choose a class color using « Color » (ex. blue for water). It is the colour that will be
eventually assigned to the class in the classified map.

4. Assign the "Class label". It is the label which will be displayed in the classified map
legend ( "Water").

5. Start to digitize (draw) the site by pressing the « New site » button. Click the left
mouse button on the image where you want to start the digitisation of your site
(release the button), you will see a dash line following the mouse moves. Digitize the
site contour using the left mouse button and double click the same mouse button to
terminate.

6. Press on the « Register site » button to record the site. The site name will then
appear in the site list of the dialog box.
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Start again these steps for each training site you want o acquire. Do not change the
color, the class number or the class label unless you are defining a new class. If, for any
reason, you are not satisfied of one site, select it in the site list and press on « Remove
site ». This will remove the site from the list.

Once finish, press on the « Save site map » button and assign the name 7msite to the
training site map.

If for any reasons you can not terminate your training site map, we will provide you one
in MapInfo MID/MIF format. You can import it using the option :

Vector -> File -> Import -> MapInfo file

Press on the « Input map » button, find the right directory and then select the
tmsite.mif file. Assign the nhame 7msite to the vector map and press « OK ».

Now you will create a set of spectral signatures using your fraining site map. These
signatures show the spectral behaviour of each object class. This means that how each
object type reflect each spectral band energy.

You will create an imagery group using the option :

Imagery -> Group

A group is a collection of raster maps or images beiing held together to be process in
the same way later.

You must select and add successively the spectral bands (#m.63, tm.b4 et tm.b5) which
will be used to compute the spectral signatures and to perform the classification. To
add new bands into the group press the « Add band » button. Do not forget to save the
group using the « Save » button . Assign the name tmgrp and press on « OK ». Close
the dialog box.

To compute the spectral signatures, choose :

Imagery -> Classification -> Signature -> Generate -> Supervised

Specify the group name (7mgrp), the training site map name (7ms/te) and assign name
tmsig to the file which will be created then press on « Generate ». Close the dialog box.

You can look at the spectral signatures using the option :
Imagery -> Classification -> Signature -> Display

Select the spectral signature file and press the « Display » button. Each object class
should show a distinct spectral behaviour. It means that the curves should not overlap.
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Optionnal ...
A more serious evaluation of the class separability can be performed using the option :
Imagery -> Classification -> Signature -> Separability

Choose the signature file fmsig and name the separability file tmsep. To look at the
results you must start the SIGIS text editor and open #msep file which is located in the
default directory “/reports". See the online help to interpret adequatly the separability
values. If the classes are well separate, you can go to classification. If not, you must go
back to the training site acquisition process.

Make sure that the monitor's region is perfectly fitted over the images you want fo
classify. To perform the classification use the option :

Imagery -> Classification -> Classify

Select the group tmgrp, then the spectral signature file #msig. Assign the name foret
to the resulting classified map. Use the minimum distance method and press on « Run ».

Important ...

You may see an error message telling you that the maximum size allowed to create
an image as been exceeded (See Help - Limitations on versions). If this happen,
use the option General -> Region (or Region -> Set Region of the monitor's drop down
menu). You will see that the number of rows or columns is greather than the
allowed limit. Fix the region over one of the image band and press on « OK ».
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Important ...(suite)

Make sure that your composite image is displayed in the monitor, then use option
Region -> Set from -> Raster of the monitor's drop down menu. You will see that the
monitors's shape change to the shape of the displayed image. Come back to the
option General -> Region and press on « OK ». This will fix the working region over
the displayed image. This method can also be used with vector maps.

Now display the raster map foret in the monitor (Display -> Raster). You should see a
raster map showing various vegetation classes, bare soil and water found in the area
covered by the map. Display classification's legend using the option :

Raster -> Information -> Legend

Select the map foret. You can modify the legend's labels by selecting a list item with
the mouse cursor, the label will then be copied in an edit box, modify the label using the
keyboard and then press « Set » button. To modify the colours related to each class
use the option Display -> Raster and press the « Color » button. Select, in the color list,
the color you want to modify and use the "Red", "Green" and "Blue" scroll bars. Press the
« Apply » button to see the result in the monitor and the « Save » button to apply the
change permanently to the raster palette.
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Tutorial 2

Virtual erection of a storage dam across the Jacques-Cartier river

Now, you will do the erection of a storage dam on the Jacques-Cartier river. You will
generate a digital elevation model from a contour map explore the dem to find the best
place to set up a dam and fix it into the landscape. Finaly, you will increase the water
level behind the dam and visualize the flooded area.

Prior to do anything else you must import the vector files provided with this tutorial.
These files are located in the folder where you do the zip file extraction. Start with the
road and power lines map. These files are Autocad DXF files. Use option:

Vector -> File -> Import -> Autocad DXF file
Press on the « Input map » button. Locate the right folder and select the energie.dxf

file. Then, press on the « Projection parameters » button to specify the projection
according to which the map has been digitized. Select the following parameters :

Projection : UTM
Ellipsoid : Clark-1866(NAD27)
Zone : 19 North

press on « OK », and on « OK » again.
Use the option:
General -> List -> Vector

You will see a file named O. It is the default name assigned by Autocad to the first
layer of a DXF file. Use the option:

General -> Rename -> Vector

and rename the file O into energy. Start again these DXF with the file road.dxf
replacing energy by road.

If no monitor are started, start one right now. Otherwise, use the one which is actually

activated and use the "Erase image" fool from the monitor's right click menu fo flush
from memory all raster maps. Close also all opened vector maps.
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Note ...

Because SIGIS is using a continuous univers, it is possible to display a raster or vector
map without seeing it. This happens when the monitor's region extents are set tfo
geographical coordinates which are covering the raster or vector map extents.

Now, display the vector maps road and energy :
Vector -> File -> Open map

Select road and energy . (use the SHIFT key to extend the selection list or CTRL to add/remove any
item of the selection)

Fix the monitor region on any of the vector layer and select :
Display -> Vector

Press the « Add layer » button and choose road and energy. Make sure that layer
enerqy is over layer road. You must select a layer in the layer list and use the « Move up
» and « Move down » buttons to achieve the right display order. Press the « Display »
button. You will see the maps in the monitor. It should be hard to see differenciate the
object which belong to different layers because they have all the same graphical
attributes. This is due to the fact that the default graphical parameters were used
while you import the 2 vector layers. To fix this problem, select the energy layer and
click on the « Editable » button located at the top of the list. The drawing ool box
should appear. Then press « OK » to close the Display vector dialog box. Use the option:

Vector -> Selection -> Polylines

The power lines should appear in dashed green. Use the "Polyline Style" ﬂ tool and
choose an appropriate color for the lines, yellow will be good. Press the « OK » button
and again the « OK » to apply the selected colour. Using the mouse, click somewhere in
the monitor to deselect everything. The objects of the map energy should appears in
their new colour. Close all the maps using :

Vector -> File -> Close map

Do not forget to answer YES when we ask you if you want to save the erergy map.

Now, you will import the contours map. It is a "shape file" like the ones produce by
ESRI's software ArcView. This time, you will select the graphical parameters to be used
before you do the importation of the vector layer. Use option :

Vector -> File -> Object Style -> Polyline style

and choose an appropriate colour for contours, orange will be nice. Do not change the
line style and press on « OK ».
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Use option:
Vector -> File -> Import -> ArcView file

Press on the « Input map » button, locate the right directory and select the
altitudell_polyline.shp file. Name the vector map a/fitude.

Using the option:
General -> Info -> Vector

and choosing a/titude, you will realize that the projection of the map is Longitude-
Latitude, the only projection supported by ArcView for its native format. You can also
see its geographical extents and its topological level. When you will display this map
(later in this exercise), you will realize that the contours are displayed with the choosen
graphical attributes.

Import the hydrography map. It is a MapInfo MID/MIF file. Use the option:

Vector -> File -> Import -> MapInfo file

Press on the « Input map » button, locate et select the Aydro.mif file. Then assign the
name /Aydro to the vector map. Here, the graphical attributes are defined in the MIF
file, so you do not have to pay attention to it.

You are now ready to begin your work. Display the vector map a/t/tude:

Vector -> File -> Open map

Select altitude.

Choose :

Display -> Vector

Press the « Add layer » button and choose a/f/fude. Then, press the « Display » button.
You will see the contour map in monitor O. Each polyline displayed in the monitor is
related o a record in a database linked to the map. To see the related data, choose :

Database -> Display

Select the a/titude database and press « OK». If you click on a numbered database
browser's gray button, you will see that the information related to this record is
selected in the browser (in red) and in the monitor (in dashed green) as well. If you
perform the inverse operation (i.e. click on a contour displayed in the monitor), the same
thing will happen. It is possible that you do not see the selected item in the database
browser. This is due to the limited number of records which can be displayed in the
browser at the same time. To look at them use :

© Géomatique SIGISCO Inc, All rights reserved 1995-2009: Reproduction forbidden without written permission



Authors: Jean Daoust & Hugues Jean, Géomatique SIGISCO Inc. Page 13 of 23

Database -> Find Selection

Use the option Region -> View entire of the monitor's drop down menu to come back the
default ZOOM factor. Close the database browser window.

Consider that the altitude is only known where there is a contour line. To know it
everywhere, we need a Digital Elevation Model (DEM). You can build such a model from a
contour map like the one you already have. To do this, you must first, convert the
vector contour lines into raster ones. This can be done using the option :

Vector -> File -> Convert -> Vector-Raster

Choose a/titude as vector and a/titude as resulting raster. Select the « From database»
button and choose "Elevation" in the variable list. This means that the value to be assign
to each cell will be found in the variable "Elevation" of the a/t/fude database. Press on
« Run ».

Display the result using :

Display -> Raster

Choose the raster map a/titude in the list and press on the « Display » button. You
should not see the raster a/t/tude because the vector layer a/t/fude should cover it with
a perfect fit. Remove the vector layer a/t/tfude from the displayed vector layer list of
monitor O, using the option :

Display -> Vector

select the layer a/tifude from the list and press on the « Remove layer » button, then
press on the « OK » button. You can also close this layer using the option :

Vector -> File -> Close map

Note ...

Remember that any layer excluded from a monitor is still opened and available for
display. The classical error consist in having several vector layers opened but not
displayed, using precious memory for nothing.

At this time, you should not see any colour variation in the monitor. This is due fo the
fact that no colour palette are linked to the newly created raster map a/titude. Press on
the « Color » button of the option Display -> Raster and select "altitude.pal" from the
colour palette list. Then, press « Load » , « Apply » and finaly « Save ». You can close
the dialog box, the palette is now permanently linked to the raster map a/titude.
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To create a continuous altitude model, you must perform an interpolation using the
option:

Raster -> Process -> Interpolation -> Contour

Choose the raster map a/titude as input raster, assign the name dem to the resulting
raster and check the option « Real ». Press the « OK» button. The interpolation
process may take some time. Once done, display the result using the option :

Display -> Raster

Use the interrogation tool ﬂ and click the left mouse button somewhere in monitor O.
You will see some values in the moveable SIGIS information bar. In the info area you
can see the altitude expressed in meters. The other values, located right to the info
area, are the position of the mouse cursor expressed in terms of raster's columns and
rows and the geographical position expressed in coordinates related to the current
working projection.

Using your digital elevation model, you can start your exploration to find the best place
to erect your dam. It could be usefull, to explore the study area in a more realistic
context. To do it, you will create a composite image close to natural colours using the
spectral bands fm.b1 (blue), tm.b2 (green) and tm.b3 (red) of the LandSat 5 satellite.
Display the histogram of the bands #m.67and #m.b2 and note the values located on both
side of the bell looking distribution (you already get the values for fm.b3). Then
choose :

Display -> Image
Load the 3 bands in their respective order and specify the minimum and maximum values.

Display the image making sure that band 1 is sent in the blue chanel, band 2 in the green
chanel and band 3 in the red chanel. You should get a composite image like this one :

Close the dialog box. Place your mouse cursor in the monitor and click on the right mouse
button to select the option:

Region -> Fix monitor on -> Raster
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then select :
Region -> Fix region

and press « OK». This will make sure that the region is perfectly fitted over the
displayed image. Open again the Display image dialog box and press the « Save raster »
button. Assign the name natural to the resulting raster and close the dialog box. Now,
you can display the raster map natural/ using the option Display -> Raster, because it is a
raster map with its own colour palette. Use now the option :

Display -> Start Monitor 3D
and manually increase the 3D monitor size to the desired size. Then use the option:
Display -> Display perspective

Specify dem as elevation and natural as drapped image. Fix the vertical exageration to
3 fo increase the perspective effect and increase the grid to 55 to get a more realistic
visual effect in the wire mesh mode. See the related help topic to know the 3D
monitor available options. Press on « Display » and close the dialog box. Use the right
mouse button in the 3D monitor to access the drop down menu. Use the option :

Tllumination -> Fix position

A sphere is displayed showing the light source position over the 3D digital model. Move
the light source position by dragging your mouse while its left button is pressed. The
illumination parameters are displayed in the information bar. Double-click the left mouse
button to go back to the 3D display mode. You can now move the viewer position by
dragging your mouse while its left button is pressed. The position parameters are also
displayed in the information bar. Use the option:

Drap image

to see the result and to get a more accurate idea of the area under survey. Close the 3D
monitor once you finish your landscape exploration.

Display your raster map dem and open and display the hydrography vector map Aydro in
monitor 0. Then, look for a place where :

e the valley straitened.

e the valley's slopes are steep.

e as downstream as possible considering the previous criterions.

You will fix your dam at this place. To represent your dam you will digitize (draw) a

o &
[

rectangular figure blocking the river over all its width. Use the measure tool
an idea of the projected dam size.

to get

Once you have find a good location for your dam, select :

Vector -> File -> New map
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Assign the name dam to the new vector map. A dialog box allowing you to define the
variables of the associated database will appear. Create a variable named "Z" and
assigned to it the real type. Then press the « Add » button and finally the « OK »

button. Then, start to digitize your dam using the polygon tool ll of the digitizatin
tool box. Be aware to close the valley with your virtual dam to make sure that the
uprising waters will not pass trough the dam sides. Once the dam is digitized, display
the associated database.

Select :

Vector -> File -> Update -> From raster

Choose the vector map dam and the raster map dem then select the option maximum and
choose variable "Z". Press on « OK ». The maximum altitude value found in your dam will
be automaticly assigned to variable "Z" associated to your dam map.

Save you map of the dam and its associated database using the option :

Vector -> File -> Save map

and close vector map dam. Keeping the goal of this tutorial in mind, we will provide you a
map showing a dam, a dike and a derivation channel to make sure that you will be able to
continue the exercise. If you want to keep your own dam map rename it. You will be able
to try this exercise later with your own dam.

The provided dam map barrage.mif is in MapInfo MID/MIF format. Import it and
assign it the name dam. Open this map and display it. Make sure that the region is
perfectly fitted over the raster map dem.

Now, you will convert your dam's vector map into a raste one. Use again the option :
Vector -> File -> Convert -> Vector - Raster

Choose dam as vector map and dam also as resulting raster. Specify that the value will
be assign according to the variable "Altitude". Then, press on « Run». Display the
result. If you close the vector map dam overlaying the raster map, you will see the
shapes related to a dam, a dike and a derivation channel.

Now, you will fix the dam into the digital elevation model using the option :

Raster -> Process -> Patch

Press the « Add » button for the first time and select dem. Press again on this button
and select dam. Assign the name demdam to the result and display it. You should get a
raster map very similar to dem with some difference only where are the dam, the dike

and the derivation channel. You are actually ready to perform the flooding of the
reservoir located behind the dam.
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Choose :
Raster -> Process -> DEM -> Flood

Select demdam as raster and flood as resulting raster. Press on the « Sel start pt »
button and click in monitor O on place located on the river just behind the dam. The
altitude of this point will be sent to the item altitude of the Flood dialog box. Replace
this value by the altitude of your dam less 5 meters, soit 452 meters (absolute elevation
of the provided dikes) less 5 meters, o be secure. Press « OK». Now display the
raster map flood.

Now, you must add the flooded reservoir f/ood to the digital elevation model demdam.
If you use the information tool to explore the map flood, you will realize that the cell
values located in the flooded areas are 1 and O everywhere else. It is in fact a boolean
map. You will create a new raster map showing the absolute altitude of the flooded
areas. Choose the option:

Raster -> Process -> Map algebra

Write the expression: flood.452 = flood™ 452

Press on « OK » and close the calculator. Display the raster map flood.452.

Because "0 * 452 = 0" and "1 * 452 = 452" you will get a map where the absolute water
level of the reservoir is 452 meters. You will fix it in the digital elevation model
demdam. Use the option:

Raster -> Process -> Patch

Press on the « Add » button for the first time and select mnabarrage. Then press on
this button again and select /inondation.452. Assign the name mnabarrage. 452 to the

result and display it. You can explore this new raster map with the information tool. It
is a new digital elevation model showing the dam erection and the flooded area.
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Optional ...

You visualize the final result in a tridimensional context. To do it, you must create a
natural composite-image taking into account the implantation of the dam and the flooded
area. Display the raster map natural/in monitor O and press the « Color » button. Then
locate, in the colour table, a colour which is very close to the one of water (ex. blue).
Select this colour using the mouse and note the number appearing in the "Colour-index"
case. Do the same thing with the dam (ex. white, index 255), note also the related colour
index. Then, using the option:

Raster -> Process -> Map algebra

Write the expression: flood.co/= flood™ #
Replace the "#" by the colour index you note for the water colour. Repeat this operation
for the dam colour using the expression :

dam.col = dam / dam™ #
Now, you must add the 2 raster maps to the map natural. Use the option:
Raster -> Process -> Patch

Press on the « Add » for the first time and choose natural. Press on this button again
and choose flood.col. Press on this button an other time and choose dam.col. Assign the
name natdam.452 to the result and display it. You will see that the new map natdam.452
is displayed in shades of gray instead of colours. You will have to copy the colour palette
of the raster map natural/to the map natdam.452. To do this, use the option :

Publishing -> Edit text file

Open the file natural (File -> Open) located in the directory "\colr". (You are actually located
in the "\reports" directory, you must move up one level and double click on the "\colr" directory then on the

“naturel" file). Then save this file, in the directory "\colr", as "natdam.452" (notify that this
technic pré-suppose that the 2 maps have the same amount of different values associated to each colour,

which is actudlly the case). Close the text editor and flush the monitor with the “Erase
image" tool. Display again the map natdam.452 in the monitor. Start the 3D monitor,
increase it size as you want, then open the "Raster 3D Display" dialog box as we already
see. Use demdam.452 as elevation map and natdam.452 as drapped image. You can save
a 3D view using the option Save 3D display of the 3D monitor drop down menu.
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Tutorial 3

Environmental impact evaluation and road planning

Actually, you have created a forestry map using the Landsat satellite imagery, virtually
erected a storage dam across the Jacques-Cartier river and flood an area located
upstream to the dam. Now you will learn how you can combine these informations to
evaluate the environmental impact of the erection of a dam on the river environment.

If no monitor are availlable start one right now. Otherwise use the one which is already
activated and use the "Erase image" tool from the monitor's right click menu to flush
from the memory all the remaining raster maps or image. Close also all opened vector
maps. Fix the region over the raster map foret and display it. Use the option Region ->
Fix monitor on -> Raster of the monitor's drop down menu then use Region -> Fix region
and press on « OK». This will ensure that the region is perfectly fitted over the
displayed image.

Now, you will evaluate the flooded superficy per class of your forestry map. You will
extract the flooded parts of your forestry map. To do this, choose the option :

Raster -> Process -> Map algebra
Werite the expression : forflood = flood™ foret.

Display raster map forflood , you will realize that you can not see anything in the
monitor. This is due to the fact that there are only 6 values, from 1 to 6, in the raster
map (your 6 classes defined in the first tutorial). Because the first colours available in
the default palette are very close to black, it is very hard to see the result. Use the
« Color » button of the option Display -> Raster, and choose the "random.pal" palette.
Press « Load », then « Apply » and finally « Save ». Close the dialog box, and look at
the results.

Then, select the option :
Raster -> Information -> Area

Choose forflood as the raster map, hectares as units and assign the name flood hec to
the resulting file. You can look at the result using the SIGIS text editor available
under the Publish menu. All reports are located in the "\reports" folder of the current
univers. By default, the SIGIS text editor try to open the files which are located in
this folder.

Now, display the f/ood raster map and the road vector map in monitor 0. You will see
that highway 175 between Québec city and Chicoutimi is partly flooded which is a little
bit . So, you will use SIGIS to find a new road path. This path will have to avoid the
flooded area and respect some criterions. These criterions will be represented by
raster maps. The first criterion consist to avoid the flooded area. The second is to
avoid the dam, the dike and the derivation channel. The third one, will prefer slopes to
steep ones. The fourth one, consist in favoring a path passing over bare soil. Finaly, the
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fifth contraint the new path to avoid, if possible, the path of the actual power lines.
The criterion raster maps are made of cells for which the value represent the cost to
cross them. The cost values are relatives and depends on the nature of the small part
of the ground covered by each cell.

To create the criterion-map no 1 use :
Raster -> Process -> Map algebra

Write the expression : criterionl = flood * 255
then press on « OK ».

To create the criterion-map no 2, reclassify the map dam using the option :
Raster -> Process -> Reclass

Select the raster map to be reclassified soit dam, assign the criterionZ to the resulting
raster map and specify the reclassification rules. These rules must be expressed in the
prévue section. Actually, only one rule is sufficient, soit 0=0, the other values will be
reclassified to 255 choosing the option « Set all other values to: » and specifiing 255 in
the corresponding edit control. Press on « Run ».

To create the criterion-map no 3, first create a slope gradient map using the option :
Raster -> Process -> Slope and Aspect

Choose demdam.452. as digital elevation model. This map shows all the topographical
information of the site under survey. Assign the name gradient to the slope map, select
the pourcent option and assign the name orientation to the aspect map. Press on «
Run ». Reclassify the slope map gradient using the option :

Raster -> Process -> Reclass

Specify gradient as the name of the raster map to be reclassified, criterion3 as the of
the resulting raster map and the reclassification rules. This time, you have several
reclassification rules to write in the section. They must tell the function that values
between 0% and 5% will be reclassified to 1 ([0,5[=1), values between 5% and 10% will be
reclassified to 2 ([5,10[=2), values between 10% et 15 % will be reclassified to 3
([10,15[=3), values between 15% and 20 % to be reclassified to 4 ([15,20[=4) and all
other values will be reclassified to 10 (« Set all other values to : » button and enter 10).
Your reclassification rules should look like this :

[0,5[=1

[5,10[=2

[10,15[=3

[15,20[=4

Press on « Run ».
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To get criterion-map no 4, reclassify the forestry map foret assigning a value of 10 to
water (1=10), 1 to bare soil (2=1), 4 to deciduous, coniferious and mixt forest (3,4,5=4)
and finaly a value of 2 to regeneration (6=2). Assign the name criterion4 to the result.

To get your last criterion, convert the power line vector map energy into a raster map
using to option :

Vector -> File -> Convert -> Vector - Raster

Choose energy as vector map and criterion5 as resulting raster map. Specify that a
« All equal » value of 50 will be assigned to all map objects and press on « Run ». Display
the result.

You must combine all the criterions together using the calculator and the expression :
criterions = criterionl + criterion? + criterion3 + criterion4 + criterion5

Now you are ready to do your optimum pathway search. This analysis will be realise in 2
steps. The first step, consist in the creation of cumulative cost surface from one or
many starting objects. The second one, consist in the search for a least cost path from
a point to one of the starting point previously used to build the cumulative cost surface.
So, you will create a vector map called starfpt contening only one starting point. Do not
create any variable in the database linked to the vector map starfpt. Use the point tool

ﬂ to digitize your point. This point must be located close to the intersection between
the actual road path and the flooded area and, of course, out of the flooded area. Place
it north east to the flooded area (close the coordinates 325096, 5223057).

Note ...

You can always look at the geographic coordinates of the active monitor's mouse cursor
in the moveable information window.

Once the digitization is done, do not forget to save the vector map using the option:
Vector -> File -> Save map

Now, do the vector-raster conversion; choose starfptas vector map, startptas resulting
raster map, select the option « All equal » value and assign a value of 1.

To perform the cost analysis use the option :

Raster -> Process -> Cost

Specify startpt as feature-raster, criterions as weight-raster and assign the name
cumcost to the result. Press on « Run». Once this has been done, display the cost map.

Tt shows a cumulative cost from your starting point. Select a "rainbow " colour palette
using the « Color » button of the Display -> Raster menu, you will see the, it looks great !
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Now, display the raster map flood, and add the vector map dam in monitor O keeping
displayed the vector map road.

Choose the option :
Raster -> Process -> Pathway

Select cumcost as raster map and roadpath as resulting vector. Select your ending point
of your path in monitor 0. This ending point should be located on a not flooded part of
the highway 175, opposite to your starting point. To do this, press on the « Sel end pt »
button and move the mouse cursor into monitor 0. A small hand with a compass should
appears. Place the hand major tip at the desired position and press the left mouse
button. The coordinates will be sent to X and Y edit box of the "Pathway" dialog box.
Try to place your point close to coordinates X : 322343 and Y : 5212625. You can also
replace these values using the keyboard if you can not reach the desired precision with
your mouse. Press on « OK». The resulting map is a vector one. Display it, it is the new
proposed road path !
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Optional ...

If a printer is connected to your computer, you can realise a map showing the proposed
path overlaying your forestry classified map and print it. Display first, what you want to
see on your map in monitor O, it means the raster map foret you have created in the
first tutorial and the vector map roaapath showing the proposed path (you can also add
the actual highway road and the dam). Then choose the option :

Publier -> New map

The default printer's dialog box will appears. Choose the size and orientation of the
paper sheet and the printing type; colour or monochrome. A virtual sheet of paper,
called a cartographic layout, and a new tool box will appears. Choose :

Publier -> Map composition

In the Map Composition dialog box, assign a title and a subtitle to your map. Check the
frame, scalebar, projection, north, legend, grid options and specify the spacing between
the grid mesh. A value of 5000 m in X and Y should be good. Press on the « Apply »

button to apply the modification to the layout. Use the select tool Ll from the
cartographic tool bar to select the object located on the layout. To move these objects,
use the same tool keeping the left mouse button pressed. Increase or decrease the size
of the selected objects using the anchor points (in green) located on the 4 corners of
each object. To modify a text object, double click on the object itself; you will have
access to a dialog box giving you the possibility to modify the font type, size and colour.
Double click also on the "legend" to access and modify its properties. To print your map,
choose :

Environment -> Print

If you have any digital photos you want to add to your map composition (ex. your 3D dam
view) you can do it if they are in windows bitmap format (.bmp). Use the place image

tool A Press on this button, then click in the cartographic layout where you want to
place your photo; a dialog box allowing you the possibility to choose your image will
appear. Select your image and press « Open ».

We hope you have enjoyed these tutorials and you realize the SIGIS great GIS
capacities.

Jean Daoust and Hugues Jean
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